summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2012-07-16 03:39:58 +0200
committerAllan McRae <allan@archlinux.org>2013-01-17 13:32:54 +0100
commit993700bc6b12cd291544d2a22845f480e8a7925e (patch)
tree61fdc3240a56a3ea1e8678b5bbf48eba1b0dfd0e /configure.ac
parentbb4d2b72c1d35ab9d65d632be0dcaf00cfa7d600 (diff)
downloadpacman-993700bc6b12cd291544d2a22845f480e8a7925e.tar.gz
pacman-993700bc6b12cd291544d2a22845f480e8a7925e.tar.xz
Do not require full path for scriptlet shell
This increases robustness to the shell location changing paths. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index aa3305db..e89d4fce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,8 +105,8 @@ AC_ARG_WITH(debug-suffix,
# Help line for changing shell used to run install scriptlets
AC_ARG_WITH(scriptlet-shell,
AS_HELP_STRING([--with-scriptlet-shell=shell],
- [set the full path to the shell used to run install scriptlets]),
- [SCRIPTLET_SHELL=$withval], [SCRIPTLET_SHELL=/bin/sh])
+ [set the shell used to run install scriptlets]),
+ [SCRIPTLET_SHELL=$withval], [SCRIPTLET_SHELL=sh])
# Help line for using OpenSSL
AC_ARG_WITH(openssl,
@@ -455,7 +455,7 @@ AC_SUBST(DEBUGSUFFIX)
AC_DEFINE_UNQUOTED([DEBUGSUFFIX], "$DEBUGSUFFIX", [The suffix for debugging symbol packages used by makepkg])
# Set shell used by install scriptlets
AC_SUBST(SCRIPTLET_SHELL)
-AC_DEFINE_UNQUOTED([SCRIPTLET_SHELL], "$SCRIPTLET_SHELL", [The full path of the shell used to run install scriptlets])
+AC_DEFINE_UNQUOTED([SCRIPTLET_SHELL], "$SCRIPTLET_SHELL", [The shell used to run install scriptlets])
# Configuration files
AC_CONFIG_FILES([