summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-04-24 18:42:51 +0200
committerDan McGee <dan@archlinux.org>2011-04-27 23:59:08 +0200
commit9c552272e83905703ad0cbcfc92883ebd1eff6f9 (patch)
tree62311be10bac21d7aa2904704dc9f0f48af49f60 /configure.ac
parent97be2f0e0a0daad2f9058377c7dbee62cc7a8718 (diff)
downloadpacman-9c552272e83905703ad0cbcfc92883ebd1eff6f9.tar.gz
pacman-9c552272e83905703ad0cbcfc92883ebd1eff6f9.tar.xz
configure: add output showing what libraries will be used
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 738cd7fa..02f9f40c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,7 +99,7 @@ AC_ARG_WITH(gpgme,
[], [with_gpgme=check])
# Check for useable libcurl
-LIBCURL_CHECK_CONFIG([yes], [7.19.4])
+LIBCURL_CHECK_CONFIG([yes], [7.19.4], [with_libcurl=yes], [with_libcurl=no])
# Help line for documentation
AC_ARG_ENABLE(doc,
@@ -151,9 +151,10 @@ AS_IF([test "x$with_openssl" != "xno"],
[if test "x$with_openssl" != "xcheck"; then
AC_MSG_FAILURE([--with-openssl was given, but -lssl was not found])
fi],
- [-lcrypto])],
+ [-lcrypto])
+ with_openssl=$ac_cv_lib_ssl_MD5_Final],
AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
+AM_CONDITIONAL([HAVE_LIBSSL], [test "x$with_openssl" = "xyes"])
# Check for gpgme
AC_MSG_CHECKING(whether to link with libgpgme)
@@ -418,6 +419,9 @@ ${PACKAGE_NAME}:
build script name : ${BUILDSCRIPT}
Compilation options:
+ Use libcurl : ${with_libcurl}
+ Use GPGME : ${with_gpgme}
+ Use OpenSSL : ${with_openssl}
Run make in doc/ dir : ${wantdoc} ${asciidoc}
Doxygen support : ${usedoxygen}
debug support : ${debug}