summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHenning Garus <henning.garus@googlemail.com>2009-08-24 22:10:47 +0200
committerDan McGee <dan@archlinux.org>2009-09-06 22:33:34 +0200
commita05757f984f526233e90a774beb571dba8270ff0 (patch)
tree7ac8e326c464cce7b3fcb159500f9aec68b308f1 /configure.ac
parent20ba3cfe4e92beab9ae368bf73c1609f2555ee9a (diff)
downloadpacman-a05757f984f526233e90a774beb571dba8270ff0.tar.gz
pacman-a05757f984f526233e90a774beb571dba8270ff0.tar.xz
Configure: Check if libfetch version is >= 2.21
Commit 6f97842 started using libfetch's conditional GET. This requires libfetch to be version 2.21 or greater. Change configure.ac to check for the existence of the last_modified field in the url struct, which was introduced with libfetch 2.21. Signed-off-by: Henning Garus <henning.garus@gmail.com> [Xav : moved AC_CHECK_MEMBER outside of AC_CHECK_LIB] Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2164b9e..2c08d790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,6 +144,11 @@ if test "x$internaldownload" = "xyes" ; then
# Check for a download library if it was actually requested
AC_CHECK_LIB([fetch], [fetchParseURL], ,
AC_MSG_ERROR([libfetch is needed to compile with internal download support]) )
+ # Check if libfetch supports conditional GET
+ # (version >=2.21, struct url has member last_modified)
+ AC_CHECK_MEMBER(struct url.last_modified, ,
+ AC_MSG_ERROR([libfetch must be version 2.21 or greater]),
+ [#include <fetch.h>] )
else
AC_MSG_RESULT(no)
fi