summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-10-30 06:20:18 +0100
committerDan McGee <dan@archlinux.org>2007-10-30 06:20:18 +0100
commitac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6 (patch)
tree4aa7171cc22a17c5e6fc91412f17589da8fd8d52 /configure.ac
parent6aeda5fbff1969befa322ef7b79664f13dea1d18 (diff)
downloadpacman-ac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6.tar.gz
pacman-ac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6.tar.xz
Pick best python program available for 'make check'
Use an autoconf macro to find us a python executable, preferring python2.5 if we can find it. From there, fall back to python2.4 and then python. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4feb9dd1..ece29985 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,7 +125,8 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_RANLIB
-AM_PROG_LIBTOOL
+AC_PROG_LIBTOOL
+AC_CHECK_PROGS([PYTHON], [python2.5 python2.4 python], [false])
# find installed gettext
AM_GNU_GETTEXT([external])