summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-05-30 17:04:49 +0200
committerDan McGee <dan@archlinux.org>2007-05-30 17:04:49 +0200
commitb6387b954f7c35d0d51978aac24ca6bd6a5308fc (patch)
treea6beb14f4280b848fafc00059c7c4a54df2db8f2 /configure.ac
parentdd926c7a1c23eab0db242184c7668f32fd4defee (diff)
downloadpacman-b6387b954f7c35d0d51978aac24ca6bd6a5308fc.tar.gz
pacman-b6387b954f7c35d0d51978aac24ca6bd6a5308fc.tar.xz
scripts: do autoconf path replacement right
This should finally get the path replacement in our scripts right. This is the way the autoconf package itself does it and should not need much further tweaking. Threw in a few trailing whitespace corrections from the scripts as well. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 6 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 126cd277..62229247 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,22 +137,22 @@ esac
# Check for architecture
case "${host}" in
- i686-*)
+ i686-*)
CARCH="i686"
CARCHFLAGS="i686"
ARCHSWITCH="march"
;;
- x86_64-*)
+ x86_64-*)
CARCH="x86_64"
CARCHFLAGS="x86-64"
ARCHSWITCH="march"
;;
- ia64-*)
+ ia64-*)
CARCH="ia64"
CARCHFLAGS="ia64"
ARCHSWITCH="march"
;;
- sparc-*)
+ sparc-*)
CARCH="sparc"
CARCHFLAGS="v9"
ARCHSWITCH="mcpu"
@@ -162,7 +162,7 @@ case "${host}" in
CARCHFLAGS="750"
ARCHSWITCH="mcpu"
;;
- i386-*)
+ i386-*)
CARCH="i386"
CARCHFLAGS="i386"
ARCHSWITCH="march"
@@ -236,15 +236,6 @@ AC_SUBST(PKGEXT)
AC_DEFINE_UNQUOTED([PM_EXT_DB], "$DBEXT", [The file extension used by pacman databases])
AC_SUBST(DBEXT)
-# Set up localedir substitution, double eval to get full path
-localedir="$(eval echo ${localedir})"
-LOCALEDIR="$(eval echo ${localedir})"
-AC_SUBST(LOCALEDIR)
-
-sysconfdir="$(eval echo ${sysconfdir})"
-SYSCONFDIR="$(eval echo ${sysconfdir})"
-AC_SUBST(SYSCONFDIR)
-
# Configuration files
AC_CONFIG_FILES([
lib/libalpm/Makefile
@@ -253,15 +244,6 @@ src/pacman/Makefile
src/pacman/po/Makefile.in
src/util/Makefile
scripts/Makefile
-scripts/abs
-scripts/gensync
-scripts/makepkg
-scripts/makeworld
-scripts/pacman-optimize
-scripts/rankmirrors
-scripts/repo-add
-scripts/repo-remove
-scripts/updatesync
doc/Makefile
etc/Makefile
etc/makepkg.conf
@@ -279,6 +261,7 @@ echo "
$PACKAGE_STRING:
prefix : ${prefix}
+ sysconfdir : $(eval echo ${sysconfdir})
source code location : ${srcdir}
compiler : ${CC}
compiler flags : ${CFLAGS}