summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-04-01 02:28:41 +0200
committerDan McGee <dan@archlinux.org>2007-04-01 02:28:41 +0200
commitb8602adee98c90c8f0f88b7aa37d134c50fb0b5c (patch)
tree6b40c9091abdac9546d5b815499caa33f26ed3d1 /configure.ac
parentc3ad8bd75fbec09d60e2c681781034a1178999cc (diff)
downloadpacman-b8602adee98c90c8f0f88b7aa37d134c50fb0b5c.tar.gz
pacman-b8602adee98c90c8f0f88b7aa37d134c50fb0b5c.tar.xz
Remove --disable-fakeroot option from configure.ac
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 5c16fbfe..2822d206 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,11 +80,6 @@ AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug], [Enable debugging support]),
[debug=$enableval], [debug=no])
-dnl Help line for fakeroot
-AC_ARG_ENABLE(fakeroot,
- AC_HELP_STRING([--disable-fakeroot], [Disable fakeroot proof support]),
- [fakeroot=$enableval], [fakeroot=yes])
-
dnl Host-dependant flags
case "${host}" in
*-*-cygwin*)
@@ -187,15 +182,6 @@ else
AC_MSG_RESULT(no)
fi
-dnl Enable or disable fakeroot code
-AC_MSG_CHECKING(for fakeroot proof support)
-if test "x$fakeroot" = "xyes" ; then
- AC_MSG_RESULT(yes)
-else
- AC_DEFINE([FAKEROOT], , [Disable fakeroot-proof code])
- AC_MSG_RESULT(no)
-fi
-
dnl Set root directory
AC_DEFINE_UNQUOTED([PM_ROOT], "$rootdir", [Location of pacman's default root directory])
@@ -266,5 +252,4 @@ pacman-$VERSION:
Compilation options:
Doxygen support : ${usedoxygen}
debug support : ${debug}
- fakeroot-proof support : ${fakeroot}
"