summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-04-08 01:36:18 +0200
committerDan McGee <dan@archlinux.org>2008-04-08 02:09:46 +0200
commitbec2ba5b4005053ce8f7048fa825ed58e3adfdc2 (patch)
tree30be07c6ff6626f984690649335ed1fc4152e6e2 /configure.ac
parent9441fba12430f568b8b7456fcbe54d4c8a42d24d (diff)
downloadpacman-bec2ba5b4005053ce8f7048fa825ed58e3adfdc2.tar.gz
pacman-bec2ba5b4005053ce8f7048fa825ed58e3adfdc2.tar.xz
Add check for swprintf() and a workaround when it is missing
We use this function once in our codebase, but fortunately the workaround is relatively easy. swprintf() is not available on Cygwin so the compile failed there, but we can do a series of mbstowcs() calls that produce the same end result as the swprintf() call. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6916329f..c695c57f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,8 +161,8 @@ AC_FUNC_FORK
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MKTIME
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS([realpath regcomp strcasecmp strdup strerror strnlen \
- strndup strrchr strsep strstr strverscmp uname geteuid])
+AC_CHECK_FUNCS([geteuid realpath regcomp strcasecmp strdup strerror \
+ strndup strrchr strsep strstr strverscmp swprintf uname])
# Enable large file support if available
AC_SYS_LARGEFILE