summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Lanzinger <mlaenz@gmail.com>2010-03-25 11:03:00 +0100
committerDan McGee <dan@archlinux.org>2010-03-26 03:28:01 +0100
commitbf7c3eb17f4de35f6639b2f3f0c1c06a27b5242b (patch)
treeb0eb3cd03361db875539ce71fabaa553801d1b6b /configure.ac
parentcdbb90aceb288034dbf4f228fc4c49da1e2ed0c0 (diff)
downloadpacman-bf7c3eb17f4de35f6639b2f3f0c1c06a27b5242b.tar.gz
pacman-bf7c3eb17f4de35f6639b2f3f0c1c06a27b5242b.tar.xz
Fix cross-compilation issues with git and libfetch
This patch fixes 2 issues I encountered when cross-compiling pacman. First is the test for libfetch which requires explicit linking to all libraries libfetch depends on. The other problem results from the AC_CHECK_PROGS test for git. This test will stop configure with an error when cross-compiling. The fix moves the call to AC_CHECK_PROG so that is only called of --enable-git is actually set. Signed-off-by: Matthias Lanzinger <mlaenz@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index faf774fd..d0fed48f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,8 +142,8 @@ if test "x$internaldownload" = "xyes" ; then
AC_MSG_RESULT(yes)
AC_DEFINE([INTERNAL_DOWNLOAD], , [Use internal download library])
# Check for a download library if it was actually requested
- AC_CHECK_LIB([fetch], [fetchParseURL], ,
- AC_MSG_ERROR([libfetch is needed to compile with internal download support]) )
+ AC_CHECK_LIB([fetch], [fetchParseURL], [AC_SUBST([LIBS], ["-lfetch -lssl -lcrypto -ldl $LIBS"])],
+ AC_MSG_ERROR([libfetch is needed to compile with internal download support]), [-lssl -lcrypto -ldl] )
# Check if libfetch supports conditional GET
# (version >=2.21, struct url has member last_modified)
AC_CHECK_MEMBER(struct url.last_modified, ,
@@ -305,10 +305,10 @@ else
fi
# Enable or disable use of git version in pacman version string
-AC_CHECK_PROGS([GIT], [git])
-AC_CHECK_FILE([.git/], hasgitdir=yes)
AC_MSG_CHECKING(whether to use git version if available)
if test "x$wantgitver" = "xyes" ; then
+ AC_CHECK_PROGS([GIT], [git])
+ AC_CHECK_FILE([.git/], hasgitdir=yes)
if test $GIT -a "x$hasgitdir" = "xyes"; then
AC_MSG_RESULT([yes])
usegitver=yes