summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-04-16 02:07:51 +0200
committerDan McGee <dan@archlinux.org>2008-04-16 02:07:51 +0200
commitbf84c232664fdce4861a2b94ce895c2b160b355a (patch)
tree874eac1acbf4c6f83407a32493b5053d76c72158 /configure.ac
parentba70c52945c9e568100ca3a4eeb3ea1208d378ad (diff)
parent0d8affeac01f40470c50e22cf721bd7a9b12050a (diff)
downloadpacman-bf84c232664fdce4861a2b94ce895c2b160b355a.tar.gz
pacman-bf84c232664fdce4861a2b94ce895c2b160b355a.tar.xz
Merge branch 'maint'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a921c72f..aeec3f15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,13 +186,20 @@ GCC_VISIBILITY_CC
# Check if we have -fgnu89-inline flag
GCC_GNU89_INLINE_CC
-# Host-dependant flags
-case "${host}" in
- *-*-cygwin*)
+# Host-dependant definitions
+case "${host_os}" in
+ cygwin*)
+ host_os_cygwin=yes
CFLAGS="$CFLAGS -DCYGWIN"
;;
+ darwin*)
+ host_os_darwin=yes
+ ;;
esac
+AM_CONDITIONAL([CYGWIN], test "x$host_os_cygwin" = "xyes")
+AM_CONDITIONAL([DARWIN], test "x$host_os_darwin" = "xyes")
+
# Check for architecture, used in default makepkg.conf
# (Note single space left after CARCHFLAGS)
case "${host}" in