summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2012-02-24 12:40:20 +0100
committerDan McGee <dan@archlinux.org>2012-03-05 18:44:34 +0100
commitcb64fbeac41308ee8c46384a126195a1fd75a361 (patch)
tree8c15263ba96093d255625a7296d61198fd2b7c0c /configure.ac
parentea7fc8962a819a04237876995140363a818202d4 (diff)
downloadpacman-cb64fbeac41308ee8c46384a126195a1fd75a361.tar.gz
pacman-cb64fbeac41308ee8c46384a126195a1fd75a361.tar.xz
Do not dereference symlinks when calculating size
Passing the "-L" flag to stat means we get the size of the file being pointed to for symlinks instead of the size of the symlink. Keep "-L" usage in repo-add as we want the actual size of the package/delta/signature there. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a1d7bfee..03f907d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,14 +219,14 @@ GCC_VISIBILITY_CC
GCC_GNU89_INLINE_CC
# Host-dependant definitions
-SIZECMD="stat -L -c %s"
+SIZECMD="stat -c %s"
SEDINPLACE="sed -i"
STRIP_BINARIES="--strip-all"
STRIP_SHARED="--strip-unneeded"
STRIP_STATIC="--strip-debug"
case "${host_os}" in
*bsd*)
- SIZECMD="stat -L -f %z"
+ SIZECMD="stat -f %z"
SEDINPLACE="sed -i \"\""
;;
cygwin*)
@@ -235,7 +235,7 @@ case "${host_os}" in
;;
darwin*)
host_os_darwin=yes
- SIZECMD="/usr/bin/stat -L -f %z"
+ SIZECMD="/usr/bin/stat -f %z"
SEDINPLACE="/usr/bin/sed -i ''"
STRIP_BINARIES=""
STRIP_SHARED="-S"