summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-09 20:38:02 +0200
committerDan McGee <dan@archlinux.org>2007-07-09 20:38:02 +0200
commitd2613b97fa8173920ef7440cf291ca24a05b5b7c (patch)
treef28857d30ca8c15141c0ec4aec03b33a6cceb1b5 /configure.ac
parentcd5b38a4b0e8cfe634b31fc730bddbc373eb17ce (diff)
downloadpacman-d2613b97fa8173920ef7440cf291ca24a05b5b7c.tar.gz
pacman-d2613b97fa8173920ef7440cf291ca24a05b5b7c.tar.xz
Add asciidoc checking to configure.ac, make manpage generation optional
Include manpages when we ship a package tarball, and allow them to be generated by the end user if they want by using the --enable-asciidoc option to ./configure. This will allow us to maintain manpages in an easier to modify format while still keeping the make dependencies to a minimum. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 25 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9a439346..17c85ad6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,11 @@ AC_ARG_ENABLE(doxygen,
AC_HELP_STRING([--disable-doxygen], [do not build API docs via Doxygen]),
[wantdoxygen=$enableval], [wantdoxygen=yes])
+# Help line for asciidoc
+AC_ARG_ENABLE(asciidoc,
+ AC_HELP_STRING([--enable-asciidoc], [build your own manpages with Asciidoc]),
+ [wantasciidoc=$enableval], [wantasciidoc=no])
+
# Help line for debug
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug], [enable debugging support]),
@@ -177,7 +182,7 @@ AC_SUBST(CARCHFLAGS)
AC_SUBST(ARCHSWITCH)
AC_SUBST(CHOST)
-# Check for doxygen support
+# Check for doxygen support and status
AC_MSG_CHECKING([for doxygen])
if test "x$wantdoxygen" = "xyes" ; then
AC_CHECK_PROGS([DOXYGEN], [doxygen])
@@ -192,7 +197,24 @@ else
AC_MSG_RESULT([no, disabled by configure])
usedoxygen=no
fi
-AM_CONDITIONAL(HAS_DOXYGEN, test "x$usedoxygen" = "xyes")
+AM_CONDITIONAL(USE_DOXYGEN, test "x$usedoxygen" = "xyes")
+
+# Check for asciidoc support and status
+AC_MSG_CHECKING([for asciidoc])
+if test "x$wantasciidoc" = "xyes" ; then
+ AC_CHECK_PROGS([ASCIIDOC], [asciidoc])
+ if test $ASCIIDOC ; then
+ AC_MSG_RESULT([yes])
+ useasciidoc=yes
+ else
+ AC_MSG_RESULT([no, asciidoc missing])
+ useasciidoc=no
+ fi
+else
+ AC_MSG_RESULT([no, disabled by configure])
+ useasciidoc=no
+fi
+AM_CONDITIONAL(USE_ASCIIDOC, test "x$useasciidoc" = "xyes")
# Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
@@ -276,6 +298,7 @@ $PACKAGE_STRING:
Compilation options:
Doxygen support : ${usedoxygen}
+ Asciidoc support : ${useasciidoc}
debug support : ${debug}
include abs : ${includeabs}
"