summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-08-06 04:03:59 +0200
committerDan McGee <dan@archlinux.org>2008-10-13 04:29:33 +0200
commitd7e502a467c054cf3bf7c50362ff7f8087b0c382 (patch)
tree16d720a682f47932609a55201a22d09aeb9e1253 /configure.ac
parent927ce2b7a52360507da3d81804520dbba4a9700d (diff)
downloadpacman-d7e502a467c054cf3bf7c50362ff7f8087b0c382.tar.gz
pacman-d7e502a467c054cf3bf7c50362ff7f8087b0c382.tar.xz
Attempt to idiot-proof making and refreshing docs
I mess this up more often than not, and maybe this will do the trick. Remove the --enable-asciidoc option as it has been superseded by the --disable-doc option in usefulness. If you want to skip building docs, you skip building all docs which is much easier when it comes to ensuring the make 'dist' and 'distcheck' targets will always build the manpages and always build the most up to date manpages. Developers shouldn't be affected in their normal builds, nor should end users of the source tarball. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 3a032d1a..c3b3722c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,11 +103,6 @@ AC_ARG_ENABLE(doxygen,
AS_HELP_STRING([--enable-doxygen], [build your own API docs via Doxygen]),
[wantdoxygen=$enableval], [wantdoxygen=no])
-# Help line for asciidoc
-AC_ARG_ENABLE(asciidoc,
- AS_HELP_STRING([--enable-asciidoc], [build your own manpages with Asciidoc]),
- [wantasciidoc=$enableval], [wantasciidoc=no])
-
# Help line for debug
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug], [enable debugging support]),
@@ -273,23 +268,6 @@ else
fi
AM_CONDITIONAL(USE_DOXYGEN, test "x$usedoxygen" = "xyes")
-# Check for asciidoc support and status
-AC_CHECK_PROGS([ASCIIDOC], [asciidoc])
-AC_MSG_CHECKING([for asciidoc])
-if test "x$wantasciidoc" = "xyes" ; then
- if test $ASCIIDOC ; then
- AC_MSG_RESULT([yes])
- useasciidoc=yes
- else
- AC_MSG_RESULT([no, asciidoc missing])
- useasciidoc=no
- fi
-else
- AC_MSG_RESULT([no, disabled by configure])
- useasciidoc=no
-fi
-AM_CONDITIONAL(USE_ASCIIDOC, test "x$useasciidoc" = "xyes")
-
# Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
if test "x$debug" = "xyes" ; then
@@ -388,7 +366,6 @@ ${PACKAGE_NAME}:
Run make in doc/ dir : ${wantdoc}
Use download library : ${internaldownload}
Doxygen support : ${usedoxygen}
- Asciidoc support : ${useasciidoc}
debug support : ${debug}
"