summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Fyfe <andrew@neptune-one.net>2007-05-31 18:21:37 +0200
committerDan McGee <dan@archlinux.org>2007-05-31 20:30:41 +0200
commite422b71a48c9f7637595c510d8766f0f38b1114e (patch)
tree33fa3c11e1ccc9e0e6a10ad50d6e4b2b249c181e /configure.ac
parent139d3c5e99fa6cb28fba7883123891a73fbb2421 (diff)
downloadpacman-e422b71a48c9f7637595c510d8766f0f38b1114e.tar.gz
pacman-e422b71a48c9f7637595c510d8766f0f38b1114e.tar.xz
Add autotool substitution for SRCEXT.
Signed-off-by: Andrew Fyfe <andrew@neptune-one.net> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a03a242a..7ab8e3a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,11 @@ AC_ARG_WITH(pkg-ext,
AC_HELP_STRING([--with-pkg-ext=ext], [Set the file extension used by packages]),
[PKGEXT=$withval], [PKGEXT=.pkg.tar.gz])
+# Help line for source package directory
+AC_ARG_WITH(src-ext,
+ AC_HELP_STRING([--with-src-ext=ext], [Set the file extension used by source packages]),
+ [SRCEXT=$withval], [SRCEXT=.src.tar.gz])
+
# Help line for database extension
AC_ARG_WITH(db-ext,
AC_HELP_STRING([--with-db-ext=ext], [Set the file extension used by the database]),
@@ -195,6 +200,9 @@ rectory])
# Set package file extension
AC_SUBST(PKGEXT)
AC_DEFINE_UNQUOTED([PKGEXT], "$PKGEXT", [The file extension used by pacman packages])
+# Set source package file extension
+AC_SUBST(SRCEXT)
+AC_DEFINE_UNQUOTED([SRCEXT], "$SRCEXT", [The file extension used by pacman source packages])
# Set database file extension
AC_SUBST(DBEXT)
AC_DEFINE_UNQUOTED([DBEXT], "$DBEXT", [The file extension used by pacman databases])
@@ -243,6 +251,7 @@ $PACKAGE_STRING:
Directory and file information:
root working directory : ${ROOTDIR}
package extension : ${PKGEXT}
+ source pkg extension : ${SRCEXT}
database extension : ${DBEXT}
Compilation options: