summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-03-29 08:46:36 +0200
committerDan McGee <dan@archlinux.org>2007-03-30 21:55:58 +0200
commite9ee9045ff4e9dd2355cb0fea781d7e166f9b345 (patch)
treecbe92adb8ca6aa121d352b37dd85012597700350 /configure.ac
parent5bc43df6f3b4d4b4f94625f7ba9e726f37d0d117 (diff)
downloadpacman-e9ee9045ff4e9dd2355cb0fea781d7e166f9b345.tar.gz
pacman-e9ee9045ff4e9dd2355cb0fea781d7e166f9b345.tar.xz
Remove unnecessary $ENV_CFLAGS from configure.ac
CFLAGS are used at build time, not configure time. We don't need to get the CFLAGS from the environment during configure. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d0d6fd36..81fce19b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,3 @@
-ENV_CFLAGS=$CFLAGS
-CFLAGS=""
-
AC_PREREQ(2.59)
dnl Update it right before the release since $pkgver_foo are all _post_ release snapshots
AC_INIT([Pacman package manager], 3.0.0, [pacman-dev@archlinux.org], [pacman])
@@ -61,7 +58,7 @@ AC_ARG_ENABLE(fakeroot,
dnl Host-dependant flags
case "${host}" in
*-*-cygwin*)
- ENV_CFLAGS="$ENV_CFLAGS -DCYGWIN"
+ CFLAGS="$CFLAGS -DCYGWIN"
;;
esac
@@ -178,9 +175,6 @@ else
AC_MSG_RESULT(no)
fi
-dnl Set CFLAGS to both $CFLAGS and ones from env ($ENV_CFLAGS)
-CFLAGS="$CFLAGS $ENV_CFLAGS"
-
dnl ==========================================================================
AC_OUTPUT([