summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-08-11 05:14:41 +0200
committerDan McGee <dan@archlinux.org>2011-08-11 18:18:39 +0200
commitf0803f6ece49e760c2992895e35517fd1cf141c9 (patch)
tree1488e6e6479c290174ea2658c18462ae77a74d53 /configure.ac
parentedd9ed6a3bbe0a351fdf09b3d4b33c8d2fd66899 (diff)
downloadpacman-f0803f6ece49e760c2992895e35517fd1cf141c9.tar.gz
pacman-f0803f6ece49e760c2992895e35517fd1cf141c9.tar.xz
build: remove mucking with CARCHFLAGS
We've never received an update to this, and gcc has sane defaults out of the box anyway, as do most projects in their build systems. Remove the magic here and just let downstream distros handle any changes or additions necessary, as we already do for LDFLAGS. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 6ad5be50..9f5b1cbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,47 +243,37 @@ AC_SUBST(STRIP_SHARED)
AC_SUBST(STRIP_STATIC)
# Check for architecture, used in default makepkg.conf
-# (Note single space left after CARCHFLAGS)
case "${host}" in
i686-*)
CARCH="i686"
- CARCHFLAGS="-march=i686 "
;;
x86_64-*)
CARCH="x86_64"
- CARCHFLAGS="-march=x86-64 "
;;
ia64-*)
CARCH="ia64"
- CARCHFLAGS="-march=ia64 "
;;
sparc-*)
CARCH="sparc"
- CARCHFLAGS="-mcpu=v9 "
;;
ppc-* | powerpc-*)
CARCH="ppc"
- CARCHFLAGS="-mcpu=750 "
;;
i386-*)
CARCH="i386"
- CARCHFLAGS="-march=i386 "
;;
arm-*)
CARCH="arm"
- CARCHFLAGS="-march=armv4 "
;;
*)
AC_MSG_WARN([[Your architecture is unknown for makepkg.conf, consider adding it to configure.ac]])
CARCH="unknown"
- CARCHFLAGS=""
;;
esac
# Now do some things common to all architectures
CHOST="${host}"
AC_SUBST(CARCH)
-AC_SUBST(CARCHFLAGS)
AC_SUBST(CHOST)
# Check for documentation support and status
@@ -407,7 +397,6 @@ ${PACKAGE_NAME}:
linker flags : ${LDFLAGS}
Architecture : ${CARCH}
- Architecture flags : ${CARCHFLAGS}
Host Type : ${CHOST}
Filesize command : ${SIZECMD}
In-place sed command : ${SEDINPLACE}