summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2011-02-09 03:05:53 +0100
committerDave Reisner <d@falconindy.com>2011-03-09 21:22:32 +0100
commitf2eac18a6ec62db3ec53744064e05416024c1b30 (patch)
tree7291505dff3663bf351a0cd37537e51cf010aaa5 /configure.ac
parent4ad4527d104c915efa912d3e1e3a543fad7aca34 (diff)
downloadpacman-f2eac18a6ec62db3ec53744064e05416024c1b30.tar.gz
pacman-f2eac18a6ec62db3ec53744064e05416024c1b30.tar.xz
Remove all traces of libfetch
Signed-off-by: Dave Reisner <d@falconindy.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 0ae9cba8..88dee2f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,11 +93,6 @@ AC_ARG_WITH(openssl,
AS_HELP_STRING([--with-openssl], [use OpenSSL crypto implementations instead of internal routines]),
[], [with_openssl=check])
-# Help line for libfetch
-AC_ARG_WITH(fetch,
- AS_HELP_STRING([--with-fetch], [use libfetch as an internal downloader]),
- [], [with_fetch=no])
-
# Help line for libcurl
AC_ARG_WITH(curl,
AS_HELP_STRING([--with-curl], [use libcurl as an internal downloader]),
@@ -166,25 +161,6 @@ AS_IF([test "x$with_curl" != "xno"],
AC_MSG_RESULT(no))
AM_CONDITIONAL([HAVE_LIBCURL], [test "x$ac_cv_lib_curl_curl_easy_perform" = "xyes"])
-# Enable or disable usage of libfetch
-AC_MSG_CHECKING(whether to link with libfetch)
-AS_IF([test "x$with_fetch" != "xno"],
- [AC_MSG_RESULT(yes)
- AC_CHECK_LIB([fetch], [fetchParseURL], ,
- [if test "x$with_fetch" != "xcheck"; then
- AC_MSG_FAILURE([--with-fetch was given, but -lfetch was not found])
- fi],
- [-lcrypto -ldl])
- # Check if libfetch supports connnection caching which we use
- AS_IF([test "x$ac_cv_lib_fetch_fetchParseURL" = "xyes"],
- [AC_CHECK_DECL(fetchConnectionCacheInit, ,
- AC_MSG_ERROR([libfetch must be version 2.28 or greater]),
- [#include <fetch.h>])
- ])
- ],
- AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBFETCH], [test "x$ac_cv_lib_fetch_fetchParseURL" = "xyes"])
-
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h glob.h libintl.h locale.h mntent.h string.h \
sys/ioctl.h sys/mount.h sys/param.h sys/statvfs.h \