summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-10-13 04:36:45 +0200
committerDan McGee <dan@archlinux.org>2008-10-13 04:36:45 +0200
commitfa02a71abd62fc8b45e92ce1652b5d98174a6dca (patch)
tree44880adf216b6a634e90e76428b265e02df33b58 /configure.ac
parent91a013a8791b73daf4d17b2d52c8dfaf12887cc6 (diff)
parent30851a24ff68b00898565a1144926d83c623e6bf (diff)
downloadpacman-fa02a71abd62fc8b45e92ce1652b5d98174a6dca.tar.gz
pacman-fa02a71abd62fc8b45e92ce1652b5d98174a6dca.tar.xz
Merge branch 'maint'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index da0a35fa..c7841b80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,11 +103,6 @@ AC_ARG_ENABLE(doxygen,
AS_HELP_STRING([--enable-doxygen], [build your own API docs via Doxygen]),
[wantdoxygen=$enableval], [wantdoxygen=no])
-# Help line for asciidoc
-AC_ARG_ENABLE(asciidoc,
- AS_HELP_STRING([--enable-asciidoc], [build your own manpages with Asciidoc]),
- [wantasciidoc=$enableval], [wantasciidoc=no])
-
# Help line for debug
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug], [enable debugging support]),
@@ -273,23 +268,6 @@ else
fi
AM_CONDITIONAL(USE_DOXYGEN, test "x$usedoxygen" = "xyes")
-# Check for asciidoc support and status
-AC_CHECK_PROGS([ASCIIDOC], [asciidoc])
-AC_MSG_CHECKING([for asciidoc])
-if test "x$wantasciidoc" = "xyes" ; then
- if test $ASCIIDOC ; then
- AC_MSG_RESULT([yes])
- useasciidoc=yes
- else
- AC_MSG_RESULT([no, asciidoc missing])
- useasciidoc=no
- fi
-else
- AC_MSG_RESULT([no, disabled by configure])
- useasciidoc=no
-fi
-AM_CONDITIONAL(USE_ASCIIDOC, test "x$useasciidoc" = "xyes")
-
# Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
if test "x$debug" = "xyes" ; then
@@ -389,7 +367,6 @@ ${PACKAGE_NAME}:
Run make in doc/ dir : ${wantdoc}
Use download library : ${internaldownload}
Doxygen support : ${usedoxygen}
- Asciidoc support : ${useasciidoc}
debug support : ${debug}
"