summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-09-06 18:20:51 +0200
committerDan McGee <dan@archlinux.org>2010-09-06 18:20:51 +0200
commitfe788ee4a68d2a8ba3bc3f938172294589c36fc4 (patch)
tree4de0ab1764f2b64502186d15cc1a11e4f33c8240 /configure.ac
parent881bf5c90f18cae47d4da06e570c934fdbdd4ecc (diff)
downloadpacman-fe788ee4a68d2a8ba3bc3f938172294589c36fc4.tar.gz
pacman-fe788ee4a68d2a8ba3bc3f938172294589c36fc4.tar.xz
Fix libfetch configure checking
I don't know what I tested in commit 3e7b90ff6950, but it definitely wasn't working as advertised. Fix the checks in the source code itself to match the right define (HAVE_LIBFETCH), as well as make sure the configure check defaults to looking for the library but not bailing if it could not be found. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4341f1f5..b4570f58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,7 +150,7 @@ AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
# Enable or disable usage of libfetch
AC_MSG_CHECKING(whether to link with libfetch)
-AS_IF([test "x$with_fetch" = "xyes"],
+AS_IF([test "x$with_fetch" != "xno"],
[AC_MSG_RESULT(yes)
AC_CHECK_LIB([fetch], [fetchParseURL], ,
[if test "x$with_fetch" != "xcheck"; then