summaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-18 03:34:30 +0200
committerDave Reisner <dreisner@archlinux.org>2012-04-24 15:54:06 +0200
commit03acea832ad39fa371781f045c39677a02d1156a (patch)
tree488c4e385749f0f08ac2286a250095048af7435e /contrib/Makefile.am
parent1b494ab77198a6cbb9c06a13435159641e2dc0c5 (diff)
downloadpacman-03acea832ad39fa371781f045c39677a02d1156a.tar.gz
pacman-03acea832ad39fa371781f045c39677a02d1156a.tar.xz
validate bash scripts with 'bash -n' during build.
Use the no-exec mode of $(BASH_SHELL) to check for syntax errors in shell scripts. Since we use the extglob feature in various places, this requires that we pass -O extglob to the shell as well, to ensure that the parser is armed to handle this syntax. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 5139b54d..3cc1e578 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -66,6 +66,7 @@ $(BASHSCRIPTS): Makefile
$(AM_V_at)$(RM) $@
$(AM_V_GEN)test -f $(srcdir)/$@.sh.in && m4 -P -I $(srcdir) $(srcdir)/$@.sh.in | $(edit) >$@
$(AM_V_at)chmod +x,a-w $@
+ @$(BASH_SHELL) -O extglob -n $@
$(OURFILES): Makefile
$(AM_V_at)$(RM) $@ $@.tmp