summaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-12-07 19:33:41 +0100
committerDan McGee <dan@archlinux.org>2011-12-08 16:17:39 +0100
commit781af8f91b5c8c6b804a0dcc0a47a7f8f018c6de (patch)
tree4799c6842ac2d0e109313088c48f04fd03759684 /contrib/Makefile.am
parentdacda1f6b3f2122d7d54cda9ed7d620301595ef1 (diff)
downloadpacman-781af8f91b5c8c6b804a0dcc0a47a7f8f018c6de.tar.gz
pacman-781af8f91b5c8c6b804a0dcc0a47a7f8f018c6de.tar.xz
Use automake verbose helpers in custom make rules
This converts our script generation to use the built-in AM_V_GEN macro, which honors the V= setting passed to make and allows one to see the full command if they truly desire. The AM_V_at macro is also used in place of an explicit @ so verbose-mode compiles show all commands being run. We can also use these two macros in doc generation to quiet it down to the level we expect. Other minor changes: * a pointless test call is removed in test/pacman/tests/ * sed is used instead of dos2unix as we depend on it anyway * consecutive chmod calls are reduced to a single call (e.g., '+x,a-x') Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index be0a4ba3..970e17b8 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -35,19 +35,16 @@ edit = sed \
-e '1s|!/bin/bash|!$(BASH_SHELL)|g'
$(OURSCRIPTS): Makefile
- @echo ' ' GEN $@;
- @$(RM) $@ $@.tmp
- @$(edit) $(srcdir)/$@.in >$@.tmp
- @chmod +x $@.tmp
- @chmod a-w $@.tmp
- @mv $@.tmp $@
+ $(AM_V_at)$(RM) $@ $@.tmp
+ $(AM_V_GEN)$(edit) $(srcdir)/$@.in >$@.tmp
+ $(AM_V_at)chmod +x,a-w $@.tmp
+ $(AM_V_at)mv $@.tmp $@
$(OURFILES): Makefile
- @echo ' ' GEN $@;
- @$(RM) $@ $@.tmp
- @$(edit) $(srcdir)/$@.in >$@.tmp
- @chmod a-w $@.tmp
- @mv $@.tmp $@
+ $(AM_V_at)$(RM) $@ $@.tmp
+ $(AM_V_GEN)$(edit) $(srcdir)/$@.in >$@.tmp
+ $(AM_V_at)chmod a-w $@.tmp
+ $(AM_V_at)mv $@.tmp $@
all-am: $(OURSCRIPTS) $(OURFILES)