summaryrefslogtreecommitdiffstats
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2011-06-30 17:07:54 +0200
committerDan McGee <dan@archlinux.org>2011-06-30 17:44:45 +0200
commit9efd10cd2ac9a7654b2c7c94df86bf09ab54f41a (patch)
tree2965273aa479462a199bfc40a358072069d14df7 /contrib/Makefile.am
parentc2cce4f3f5e0381d107ced3fee3ab0d7240653d1 (diff)
downloadpacman-9efd10cd2ac9a7654b2c7c94df86bf09ab54f41a.tar.gz
pacman-9efd10cd2ac9a7654b2c7c94df86bf09ab54f41a.tar.xz
fix vim syntax highlighting of .sh files
vim recognises what type of shell script it's dealing with by looking at the shebang. If detection fails it falls back to sh which doesn't support some bash features. Adding a normal, possibly broken, shebang which gets fixed by the Makefile allows vim to detect bash syntax. Signed-off-by: Florian Pritz <bluewind@xinu.at> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index e9f77940..cba2085c 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -27,7 +27,7 @@ MOSTLYCLEANFILES = $(OURSCRIPTS) $(OURFILES) *.tmp
edit = sed \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
- -e 's|@BASH_SHELL[@]|$(BASH_SHELL)|g'
+ -e '1s|!/bin/bash|!$(BASH_SHELL)|g'
$(OURSCRIPTS): Makefile
@echo ' ' GEN $@;