summaryrefslogtreecommitdiffstats
path: root/contrib/PKGBUILD.proto
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-11 16:59:27 +0200
committerDan McGee <dan@archlinux.org>2007-07-11 17:03:33 +0200
commit147a32b32de4ebcbb51c963f2573d9218d9a2eb9 (patch)
treeddf00f4d5111709980fe5462d5720b503d783b63 /contrib/PKGBUILD.proto
parentcb164c3130f15b22dbf16991c28ba609cd2f79de (diff)
downloadpacman-147a32b32de4ebcbb51c963f2573d9218d9a2eb9.tar.gz
pacman-147a32b32de4ebcbb51c963f2573d9218d9a2eb9.tar.xz
Add {PKGBUILD,install}.proto to contrib/ directory
Also update README and Makefile.am in the contrib/ directory. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'contrib/PKGBUILD.proto')
-rw-r--r--contrib/PKGBUILD.proto35
1 files changed, 35 insertions, 0 deletions
diff --git a/contrib/PKGBUILD.proto b/contrib/PKGBUILD.proto
new file mode 100644
index 00000000..9e4b69a0
--- /dev/null
+++ b/contrib/PKGBUILD.proto
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=NAME
+pkgver=VERSION
+pkgrel=1
+pkgdesc=""
+arch=()
+url=""
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: