summaryrefslogtreecommitdiffstats
path: root/contrib/PKGBUILD.vim
diff options
context:
space:
mode:
authorChantry Xavier <shiningxc@gmail.com>2008-03-09 23:46:35 +0100
committerDan McGee <dan@archlinux.org>2008-03-11 01:12:20 +0100
commit6820be9ba1e760e66df1d4cc1a73c04b55bdb00a (patch)
treeb515671d9d58d6995e345d938fabbe1f94933f70 /contrib/PKGBUILD.vim
parent804ab37ea62602b04ae7b65c3e7fddda12bbae5d (diff)
downloadpacman-6820be9ba1e760e66df1d4cc1a73c04b55bdb00a.tar.gz
pacman-6820be9ba1e760e66df1d4cc1a73c04b55bdb00a.tar.xz
PKGBUILD.vim: improve invalid arch/license detection.
If we had : arch=(fake) The fake string would be highlighted because it's invalid. But if we had : arch=('fake') it didn't work. Fix this for both arch and license arrays. Signed-off-by: Chantry Xavier <shiningxc@gmail.com>
Diffstat (limited to 'contrib/PKGBUILD.vim')
-rw-r--r--contrib/PKGBUILD.vim6
1 files changed, 3 insertions, 3 deletions
diff --git a/contrib/PKGBUILD.vim b/contrib/PKGBUILD.vim
index bf4b2ee5..7aacafb6 100644
--- a/contrib/PKGBUILD.vim
+++ b/contrib/PKGBUILD.vim
@@ -57,7 +57,7 @@ syn keyword pb_k_license license contained
syn keyword pbLicense APACHE CDDL EPL FDL GPL LGPL MPL PHP RUBY ZLIB ISC MIT BSD contained
syn match pbLicenseCustom /custom\(:[[:alnum:]]*\)*/ contained
syn match pbIllegalLicense /[^='"() ]/ contained contains=pbLicenseCustom,pbLicense
-syn region pbLicenseGroup start=/^license=(/ end=/)/ contains=pb_k_license,pbLicenseCustom,pbLicense,pbIllegalLicense,shDoubleQuote,shSingleQuote
+syn region pbLicenseGroup start=/^license=(/ end=/)/ contains=pb_k_license,pbLicenseCustom,pbLicense,pbIllegalLicense
" backup
syn keyword pb_k_backup backup contained
@@ -67,8 +67,8 @@ syn region pbBackupGroup start=/^backup=(/ end=/)/ contains=pb_k_backup,pbValidB
" arch
syn keyword pb_k_arch arch contained
syn keyword pbArch i686 x86_64 ppc contained
-syn match pbIllegalArch /[^='() ]/ contained contains=pbArch
-syn region pbArchGroup start=/^arch=(/ end=/)/ contains=pb_k_arch,pbArch,pbIllegalArch,shDoubleQuote,shSingleQuote
+syn match pbIllegalArch /[^='"() ]/ contained contains=pbArch
+syn region pbArchGroup start=/^arch=(/ end=/)/ contains=pb_k_arch,pbArch,pbIllegalArch
" groups
syn keyword pb_k_groups groups contained