summaryrefslogtreecommitdiffstats
path: root/contrib/PKGBUILD.vim
diff options
context:
space:
mode:
authorChantry Xavier <shiningxc@gmail.com>2008-03-13 00:25:38 +0100
committerChantry Xavier <shiningxc@gmail.com>2008-03-16 23:22:17 +0100
commitdae3f9deefdb86f726a68dc89a7391e9df7517df (patch)
tree12d2a8a552d42f1e567557f699021fe5e4c713fa /contrib/PKGBUILD.vim
parent35135c0a0cbac592e72296c0ca64e9def0308942 (diff)
downloadpacman-dae3f9deefdb86f726a68dc89a7391e9df7517df.tar.gz
pacman-dae3f9deefdb86f726a68dc89a7391e9df7517df.tar.xz
Add zipman makepkg option.
All other steps in tidy_install function were already controlled by an option in makepkg.conf, so this patch adds an option for the man page compression step too. This will allow to keep man pages uncompressed, which is required for some special meta man page, like the zshall one (see FS#4580). Ref: http://www.archlinux.org/pipermail/pacman-dev/2008-March/011472.html Signed-off-by: Chantry Xavier <shiningxc@gmail.com>
Diffstat (limited to 'contrib/PKGBUILD.vim')
-rw-r--r--contrib/PKGBUILD.vim2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/PKGBUILD.vim b/contrib/PKGBUILD.vim
index bf4b2ee5..179f40bf 100644
--- a/contrib/PKGBUILD.vim
+++ b/contrib/PKGBUILD.vim
@@ -151,7 +151,7 @@ hi def link pbValidSha1sums Number
" options
syn keyword pb_k_options options contained
-syn match pbOptions /\(no\)\?\(strip\|docs\|libtool\|emptydirs\|ccache\|distcc\|makeflags\|force\)/ contained
+syn match pbOptions /\(no\)\?\(strip\|docs\|libtool\|emptydirs\|zipman\|ccache\|distcc\|makeflags\|force\)/ contained
syn match pbOptionsNeg /\!/ contained
syn match pbOptionsDeprec /no/ contained
syn region pbOptionsGroup start=/^options=(/ end=/)/ contains=pb_k_options,pbOptions,pbOptionsNeg,pbOptionsDeprec,pbIllegalOption,shDoubleQuote,shSingleQuote