summaryrefslogtreecommitdiffstats
path: root/contrib/doc/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2016-10-09 14:52:27 +0200
committerAllan McRae <allan@archlinux.org>2016-10-10 02:38:05 +0200
commit0c99eabd50752310f42ec808c8734a338122ec86 (patch)
tree499801a8c046001ddab0b11439e9e948b257d726 /contrib/doc/Makefile.am
parent2e76c184aac74c4848fa5ee092fe54c9954c4054 (diff)
downloadpacman-0c99eabd50752310f42ec808c8734a338122ec86.tar.gz
pacman-0c99eabd50752310f42ec808c8734a338122ec86.tar.xz
Remove contrib
The contrib directory takes too much of the pacman developer's limited time, which could be better spent developing and reviewing patches for the primary projects. The community can pick this up in a separate repository if wanted. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'contrib/doc/Makefile.am')
-rw-r--r--contrib/doc/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/contrib/doc/Makefile.am b/contrib/doc/Makefile.am
deleted file mode 100644
index d5725b1e..00000000
--- a/contrib/doc/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
-# We have to do some funny stuff here with the manpages. In order to ensure
-# a dist tarball doesn't get put out there without manpages, we keep those
-# files listed in EXTRA_DIST no matter what. However, we only add them to
-# man_MANS if --enable-asciidoc and/or --enable-doxygen are used.
-
-ASCIIDOC_MANS = \
- verify-pacman-repo-db.1 \
- bacman.8
-
-EXTRA_DIST = \
- asciidoc.conf \
- footer.txt \
- verify-pacman-repo-db.1.txt \
- bacman.8.txt \
- $(ASCIIDOC_MANS)
-
-# Files that should be removed, but which Automake does not know.
-MOSTLYCLEANFILES = *.xml $(ASCIIDOC_MANS)
-
-# Ensure manpages are fresh when building a dist tarball
-dist-hook:
- $(MAKE) $(AM_MAKEFLAGS) clean
- $(MAKE) $(AM_MAKEFLAGS) all
-
-if USE_GIT_VERSION
-GIT_VERSION := $(shell sh -c 'git describe --abbrev=4 --dirty | sed s/^v//')
-REAL_PACKAGE_VERSION = $(GIT_VERSION)
-else
-REAL_PACKAGE_VERSION = $(PACKAGE_VERSION)
-endif
-
-man_MANS =
-dist_man_MANS = $(ASCIIDOC_MANS)
-
-pkgdatadir = ${datadir}/${PACKAGE}
-
-ASCIIDOC_OPTS = \
- -f $(srcdir)/asciidoc.conf \
- -a pacman_version="$(REAL_PACKAGE_VERSION)" \
- -a pacman_date="`date +%Y-%m-%d`" \
- -a pkgdatadir=$(pkgdatadir) \
- -a localstatedir=$(localstatedir) \
- -a sysconfdir=$(sysconfdir) \
- -a datarootdir=$(datarootdir)
-
-A2X_OPTS = \
- --no-xmllint \
- -d manpage \
- -f manpage \
- --xsltproc-opts='-param man.endnotes.list.enabled 0 -param man.endnotes.are.numbered 0'
-
-# These rules are due to the includes and files of the asciidoc text
-$(ASCIIDOC_MANS): asciidoc.conf footer.txt Makefile.am
- $(AM_V_GEN)a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS) --out-file=./$@" $(srcdir)/$@.txt
-
-# Dependency rules
-verify-pacman-repo-db.1: verify-pacman-repo-db.1.txt
-bacman.8: bacman.8.txt
-
-# vim:set noet: