summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-13 06:36:20 +0100
committerDan McGee <dan@archlinux.org>2007-11-13 07:13:05 +0100
commit103c3ac5a789dc0ec9855c18800a0616940351b1 (patch)
tree237daae0362a954af007c1f0d9ba1a6c993101ce /doc/Makefile.am
parent1b2817f539eb3cd94b48b49736016e0bfedf3e49 (diff)
downloadpacman-103c3ac5a789dc0ec9855c18800a0616940351b1.tar.gz
pacman-103c3ac5a789dc0ec9855c18800a0616940351b1.tar.xz
configure: Doxygen is disabled by default; manpages are included in dist
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a42141fa..abc761b8 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,7 +1,7 @@
# We have to do some funny stuff here with the manpages. In order to ensure
# a dist tarball doesn't get put out there without manpages, we keep those
# files listed in EXTRA_DIST no matter what. However, we only add them to
-# man_MANS if --enable-asciidoc was used.
+# man_MANS if --enable-asciidoc and/or --enable-doxygen are used.
ASCIIDOC_MANS = \
pacman.8 \
@@ -12,14 +12,15 @@ ASCIIDOC_MANS = \
pacman.conf.5 \
libalpm.3
-if USE_DOXYGEN
DOXYGEN_MANS = $(wildcard man3/*.3)
-endif
+
+man_MANS =
if USE_ASCIIDOC
-man_MANS = $(ASCIIDOC_MANS) $(DOXYGEN_MANS)
-else
-man_MANS = $(DOXYGEN_MANS)
+man_MANS += $(ASCIIDOC_MANS)
+endif
+if USE_DOXYGEN
+man_MANS += $(DOXYGEN_MANS)
endif
EXTRA_DIST = \
@@ -33,7 +34,8 @@ EXTRA_DIST = \
libalpm.3.txt \
footer.txt \
Doxyfile \
- $(ASCIIDOC_MANS)
+ $(ASCIIDOC_MANS) \
+ $(DOXYGEN_MANS)
# Files that should be removed, but which Automake does not know.
MOSTLYCLEANFILES = $(DOXYGEN_MANS) *.xml