summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-12-22 06:47:18 +0100
committerDan McGee <dan@archlinux.org>2007-12-29 03:06:58 +0100
commit26c05b1c8c6fe639cd4eea5decac694c86cc7c00 (patch)
tree072c3b517bad8d76dc9f7a94e03260fa6d956a0a /doc/Makefile.am
parentfdab7207e2bc96ca0f22397a0073f5d1a9c2a2c7 (diff)
downloadpacman-26c05b1c8c6fe639cd4eea5decac694c86cc7c00.tar.gz
pacman-26c05b1c8c6fe639cd4eea5decac694c86cc7c00.tar.xz
Ensure that manpages are always distributed and installed
Commit 012f7939784358b02726c169543aa99436439335 was a bit misguided in its thinking, and resulted in a package built without asciidoc enabled not installing the manpages to the system on a 'make install' operation. Fix this behavior by making manpages required in a normal build, and in order to disable their existence, the '--disable-doc' option must be used. Hopefully this solves manpage issues for both developers and package builders while allowing as much flexibility as possible. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index abc761b8..3e469294 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -14,15 +14,6 @@ ASCIIDOC_MANS = \
DOXYGEN_MANS = $(wildcard man3/*.3)
-man_MANS =
-
-if USE_ASCIIDOC
-man_MANS += $(ASCIIDOC_MANS)
-endif
-if USE_DOXYGEN
-man_MANS += $(DOXYGEN_MANS)
-endif
-
EXTRA_DIST = \
pacman.8.txt \
makepkg.8.txt \
@@ -38,9 +29,15 @@ EXTRA_DIST = \
$(DOXYGEN_MANS)
# Files that should be removed, but which Automake does not know.
-MOSTLYCLEANFILES = $(DOXYGEN_MANS) *.xml
+MOSTLYCLEANFILES = *.xml
+MAINTAINERCLEANFILES = $(ASCIIDOC_MANS)
+
+man_MANS =
+dist_man_MANS = $(ASCIIDOC_MANS)
if USE_DOXYGEN
+man_MANS += $(DOXYGEN_MANS)
+
all: doxygen.in
doxygen.in: