summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-10-13 21:49:48 +0200
committerDan McGee <dan@archlinux.org>2011-10-13 21:53:52 +0200
commit43cad9c871f32da7a5342ba8b68aa316d7e47e9e (patch)
treebf3eb4431dbf0f0d5dff8a9fcf63cc7e6de25226 /doc/Makefile.am
parent04fd320e97770911894fb06ba98f3c17fc30c7d9 (diff)
downloadpacman-43cad9c871f32da7a5342ba8b68aa316d7e47e9e.tar.gz
pacman-43cad9c871f32da7a5342ba8b68aa316d7e47e9e.tar.xz
doc: update .gitignore, add CSS override for new tables usage
* Make all docs depend on Makefile; if we change flags here we want them rebuilt. * Add explicit filenames to .gitignore so we can add our own CSS override file, and add an asciidoc-override.css resource. * Adjust a few asciidoc options when generating HTML. * Remove asciidoc-manpage.css; apparantly this doesn't exist anymore. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index aa27b506..f449e727 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -41,6 +41,7 @@ HTML_DOCS = \
EXTRA_DIST = \
asciidoc.conf \
+ asciidoc-override.css \
pacman.8.txt \
makepkg.8.txt \
repo-add.8.txt \
@@ -91,8 +92,9 @@ html: $(HTML_DOCS)
website: html
bsdtar czf website.tar.gz $(HTML_DOCS) \
+ asciidoc-override.css \
-C /etc/asciidoc/stylesheets/ \
- asciidoc.css asciidoc-manpage.css \
+ asciidoc.css \
-C /etc/asciidoc/javascripts/ \
asciidoc.js \
-C /etc/asciidoc/ \
@@ -116,7 +118,7 @@ A2X_OPTS = \
--destination-dir='./'
# These rules are due to the includes and files of the asciidoc text
-$(ASCIIDOC_MANS): asciidoc.conf footer.txt
+$(ASCIIDOC_MANS): asciidoc.conf footer.txt Makefile
a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS) --out-file=./$@.xml" $(srcdir)/$@.txt
%.html: %.txt
@@ -128,9 +130,9 @@ HACKING.html: ../HACKING
dos2unix $@
# Customizations for certain HTML docs
-$(HTML_MANPAGES): asciidoc.conf footer.txt
-$(HTML_OTHER): asciidoc.conf
-%.html: ASCIIDOC_OPTS += -a linkcss -a toc -a icons
+$(HTML_MANPAGES): asciidoc.conf footer.txt Makefile
+$(HTML_OTHER): asciidoc.conf Makefile
+%.html: ASCIIDOC_OPTS += -a linkcss -a toc -a icons -a max-width=960px -a stylesheet=asciidoc-override.css
%.8.html: ASCIIDOC_OPTS += -d manpage
%.5.html: ASCIIDOC_OPTS += -d manpage
%.3.html: ASCIIDOC_OPTS += -d manpage