summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorCedric Staniewski <cedric@gmx.ca>2009-12-21 20:26:28 +0100
committerDan McGee <dan@archlinux.org>2010-03-15 00:34:16 +0100
commit5fe41df8a9eaac288433a54e216f96b1fe729c01 (patch)
tree489613b7b44d05b6a10190a134b19858192e2732 /doc/Makefile.am
parent22331fdadb1b055030a6f68e2bb9eed589187a10 (diff)
downloadpacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.gz
pacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.xz
makepkg: make strip options configurable
The newly added variables STRIP_BINARIES, STRIP_SHARED and STRIP_STATIC, that are set in makepkg.conf, specify the strip options used on binaries and shared and static libraries. In addition, files are now stripped more aggressively by default. Implements FS#13592 the way it was suggested by Allan in the comments. Signed-off-by: Cedric Staniewski <cedric@gmx.ca> Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index fcbcab88..d2f6b35a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -66,6 +66,12 @@ else
REAL_PACKAGE_VERSION = $(PACKAGE_VERSION)
endif
+#### Taken from the autoconf scripts Makefile.am ####
+edit = sed \
+ -e 's|@STRIP_BINARIES[@]|$(STRIP_BINARIES)|g' \
+ -e 's|@STRIP_SHARED[@]|$(STRIP_SHARED)|g' \
+ -e 's|@STRIP_STATIC[@]|$(STRIP_STATIC)|g'
+
man_MANS =
dist_man_MANS = $(ASCIIDOC_MANS) repo-remove.8
@@ -93,8 +99,11 @@ A2X_OPTS = \
--xsltproc-opts='-param man.endnotes.list.enabled 0 -param man.endnotes.are.numbered 0'
# These rules are due to the includes and files of the asciidoc text
-$(ASCIIDOC_MANS): asciidoc.conf footer.txt
- a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.txt
+$(ASCIIDOC_MANS): asciidoc.conf footer.txt Makefile
+ @echo GEN $@;
+ @test -f $(srcdir)/$@.txt && $(edit) $(srcdir)/$@.txt >$@.tmp || true
+ a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.tmp
+ @rm -f $@.tmp
%.html: %.txt
asciidoc $(ASCIIDOC_OPTS) -a linkcss $*.txt