summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-09 20:38:02 +0200
committerDan McGee <dan@archlinux.org>2007-07-09 20:38:02 +0200
commitd2613b97fa8173920ef7440cf291ca24a05b5b7c (patch)
treef28857d30ca8c15141c0ec4aec03b33a6cceb1b5 /doc/Makefile.am
parentcd5b38a4b0e8cfe634b31fc730bddbc373eb17ce (diff)
downloadpacman-d2613b97fa8173920ef7440cf291ca24a05b5b7c.tar.gz
pacman-d2613b97fa8173920ef7440cf291ca24a05b5b7c.tar.xz
Add asciidoc checking to configure.ac, make manpage generation optional
Include manpages when we ship a package tarball, and allow them to be generated by the end user if they want by using the --enable-asciidoc option to ./configure. This will allow us to maintain manpages in an easier to modify format while still keeping the make dependencies to a minimum. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am29
1 files changed, 16 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index f790f585..ad251287 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -7,12 +7,12 @@ ASCIIDOC_MANS = \
pacman.conf.5 \
libalpm.3
-man_MANS = $(ASCIIDOC_MANS)
-
-if HAS_DOXYGEN
-man_MANS += $(wildcard man3/*.3)
+if USE_DOXYGEN
+DOXYGEN_MANS = $(wildcard man3/*.3)
endif
+man_MANS = $(ASCIIDOC_MANS) $(DOXYGEN_MANS)
+
EXTRA_DIST = \
pacman.8.txt \
makepkg.8.txt \
@@ -23,24 +23,26 @@ EXTRA_DIST = \
pacman.conf.5.txt \
libalpm.3.txt \
footer.txt \
- Doxyfile
+ Doxyfile \
+ $(ASCIIDOC_MANS)
# Files that should be removed, but which Automake does not know.
-MOSTLYCLEANFILES = $(man_MANS) man3/*.3 *.xml
-
-ASCIIDOC_OPTS = \
- -f asciidoc.conf \
- -a pacman_version="$(PACKAGE_VERSION)" \
- -a pacman_date="`date +%Y-%m-%d`" \
- -a sysconfdir=$(sysconfdir)
+MOSTLYCLEANFILES = $(DOXYGEN_MANS) *.xml
-if HAS_DOXYGEN
+if USE_DOXYGEN
all: doxygen.in
doxygen.in:
doxygen $(srcdir)/Doxyfile
endif
+if USE_ASCIIDOC
+ASCIIDOC_OPTS = \
+ -f asciidoc.conf \
+ -a pacman_version="$(PACKAGE_VERSION)" \
+ -a pacman_date="`date +%Y-%m-%d`" \
+ -a sysconfdir=$(sysconfdir)
+
$(ASCIIDOC_MANS):
a2x -d manpage -f manpage --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.txt
@@ -53,5 +55,6 @@ PKGBUILD.5: PKGBUILD.5.txt PKGBUILD-example.txt
makepkg.conf.5: makepkg.conf.5.txt
pacman.conf.5: pacman.conf.5.txt
libalpm.3: libalpm.3.txt
+endif
# vim:set ts=2 sw=2 noet: