summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-06 22:54:18 +0200
committerDan McGee <dan@archlinux.org>2007-07-09 19:47:56 +0200
commite412ac19f549afa26b58dbd2a2090ed95ca9cb95 (patch)
tree2b3555572d5095c7bbe6457550a04aa3919e5033 /doc/Makefile.am
parentf1fac6abfb676b081ee2d474ab3e15f6d07d0416 (diff)
downloadpacman-e412ac19f549afa26b58dbd2a2090ed95ca9cb95.tar.gz
pacman-e412ac19f549afa26b58dbd2a2090ed95ca9cb95.tar.xz
Asciidoc updates- make it pretty, fix build, etc.
* Fix up the target so we rebuild the manpages when we edit the corresponding text file. * Add vim modelines to all of the asciidoc files ensureing the right syntax highlighting is used and we have expandtabs turned off. * Start making a few small changes to PKGBUILD.5 to make it pretty in both HTML and manpage format output. * Fix the manlink macro to include the manpage section in the link. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 308f338b..89f2a639 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,4 +1,4 @@
-man_MANS = \
+ASCIIDOC_MANS = \
pacman.8 \
makepkg.8 \
PKGBUILD.5 \
@@ -6,6 +6,8 @@ man_MANS = \
pacman.conf.5 \
libalpm.3
+man_MANS = $(ASCIIDOC_MANS)
+
if HAS_DOXYGEN
man_MANS += $(wildcard man3/*.3)
endif
@@ -37,9 +39,16 @@ doxygen.in:
doxygen $(srcdir)/Doxyfile
endif
-$(man_MANS): footer.txt
+$(ASCIIDOC_MANS):
a2x -d manpage -f manpage --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.txt
-PKGBUILD.5: PKGBUILD-example.txt
+# These rules are due to the includes and files of the asciidoc text
+$(ASCIIDOC_MANS): footer.txt
+pacman.8: pacman.8.txt
+makepkg.8: makepkg.8.txt
+PKGBUILD.5: PKGBUILD.5.txt PKGBUILD-example.txt
+makepkg.conf.5: makepkg.conf.5.txt
+pacman.conf.5: pacman.conf.5.txt
+libalpm.3: libalpm.3.txt
# vim:set ts=2 sw=2 noet: