summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD-example.txt
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-08 01:58:04 +0100
committerDan McGee <dan@archlinux.org>2007-11-08 02:03:58 +0100
commit23745a7bf24ffd0c44279019563502568cc1c5fb (patch)
treea1da6442d0826cc6a03571beeb3b363c25cfccc6 /doc/PKGBUILD-example.txt
parent0e83f12f4aca7abc5131b5292302f4ac9de1b56b (diff)
downloadpacman-23745a7bf24ffd0c44279019563502568cc1c5fb.tar.gz
pacman-23745a7bf24ffd0c44279019563502568cc1c5fb.tar.xz
Update the PKGBUILD example in the manpages
The old one was old. Use something a bit more recent and a bit simpler as well so it actually looks OK in the manpage. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/PKGBUILD-example.txt')
-rw-r--r--doc/PKGBUILD-example.txt36
1 files changed, 12 insertions, 24 deletions
diff --git a/doc/PKGBUILD-example.txt b/doc/PKGBUILD-example.txt
index 50b652bd..2cc53808 100644
--- a/doc/PKGBUILD-example.txt
+++ b/doc/PKGBUILD-example.txt
@@ -1,32 +1,20 @@
-# $Id: PKGBUILD,v 1.16 2006/06/20 07:03:04 tpowa Exp $
# Maintainer: judd <jvinet@zeroflux.org>
-pkgname=module-init-tools
-pkgver=3.2.2
+
+pkgname=patch
+pkgver=2.5.4
pkgrel=3
-pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
+pkgdesc="A utility to apply patch files to original sources"
arch=(i686 x86_64)
-url="http://www.kernel.org"
+url="http://www.gnu.org/software/patch/patch.html"
license=('GPL')
-depends=('glibc')
-conflicts=('modutils')
-replaces=('modutils')
-backup=('etc/modprobe.conf' 'etc/modules.conf' 'etc/modprobe.devfs')
-source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
- makefile.patch modprobe.conf)
-md5sums=('a1ad0a09d3231673f70d631f3f5040e9' '47e14fda7a46668290d11d0444d81826'\
- '6db59d41e04941a790f80c1a4432faef')
+groups=('base-devel')
+depends=('glibc' 'ed')
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('ee5ae84d115f051d87fcaaef3b4ae782')
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- patch -Np1 -i ../makefile.patch || return 1
- sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
-
- ./configure --prefix=/usr --exec-prefix=/
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
make || return 1
-
- INSTALL=/bin/install make DESTDIR="$pkgdir" install
- install -D -m644 ../modprobe.conf "$pkgdir"/etc/modprobe.conf
+ make prefix=$startdir/pkg/usr install
}
-
-# vim:set ts=2 sw=2 et: