summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD-example.txt
diff options
context:
space:
mode:
authorAndrew Fyfe <andrew@neptune-one.net>2007-07-06 17:30:53 +0200
committerDan McGee <dan@archlinux.org>2007-07-09 19:47:56 +0200
commitf1fac6abfb676b081ee2d474ab3e15f6d07d0416 (patch)
tree63c1469b3217059805097e5227e9a3f57ff73c48 /doc/PKGBUILD-example.txt
parentab87657b937f3de392b1796e7f93c4008cc21f01 (diff)
downloadpacman-f1fac6abfb676b081ee2d474ab3e15f6d07d0416.tar.gz
pacman-f1fac6abfb676b081ee2d474ab3e15f6d07d0416.tar.xz
Update PKGBUILD example.
Signed-off-by: Andrew Fyfe <andrew@neptune-one.net>
Diffstat (limited to 'doc/PKGBUILD-example.txt')
-rw-r--r--doc/PKGBUILD-example.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/doc/PKGBUILD-example.txt b/doc/PKGBUILD-example.txt
new file mode 100644
index 00000000..50b652bd
--- /dev/null
+++ b/doc/PKGBUILD-example.txt
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD,v 1.16 2006/06/20 07:03:04 tpowa Exp $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=module-init-tools
+pkgver=3.2.2
+pkgrel=3
+pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
+arch=(i686 x86_64)
+url="http://www.kernel.org"
+license=('GPL')
+depends=('glibc')
+conflicts=('modutils')
+replaces=('modutils')
+backup=('etc/modprobe.conf' 'etc/modules.conf' 'etc/modprobe.devfs')
+source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
+ makefile.patch modprobe.conf)
+md5sums=('a1ad0a09d3231673f70d631f3f5040e9' '47e14fda7a46668290d11d0444d81826'\
+ '6db59d41e04941a790f80c1a4432faef')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -Np1 -i ../makefile.patch || return 1
+ sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
+
+ ./configure --prefix=/usr --exec-prefix=/
+ make || return 1
+
+ INSTALL=/bin/install make DESTDIR="$pkgdir" install
+ install -D -m644 ../modprobe.conf "$pkgdir"/etc/modprobe.conf
+}
+
+# vim:set ts=2 sw=2 et: