summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD.5.txt
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2009-01-16 13:20:05 +0100
committerAllan McRae <allan@archlinux.org>2009-01-16 13:20:05 +0100
commit08034ceb1767f4bcbb7b440bcbfed1bc76881d16 (patch)
treed12fdaa7fb58cbf7ffa64a2909793acf088e6e42 /doc/PKGBUILD.5.txt
parent219cb2eaacf1ff35bd04cd64d0f8b616a732e185 (diff)
downloadpacman-08034ceb1767f4bcbb7b440bcbfed1bc76881d16.tar.gz
pacman-08034ceb1767f4bcbb7b440bcbfed1bc76881d16.tar.xz
makepkg: add optional package function
This patch allows us to split the building and packaging stages of a PKGBUILD and minimize fakeroot usage. This can be done with less code duplication (run_build and run_package look quite similiar) but the run_package function will be where the package splitting logic is implemented in the future. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'doc/PKGBUILD.5.txt')
-rw-r--r--doc/PKGBUILD.5.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/PKGBUILD.5.txt b/doc/PKGBUILD.5.txt
index 96c7a505..04eacfac 100644
--- a/doc/PKGBUILD.5.txt
+++ b/doc/PKGBUILD.5.txt
@@ -256,6 +256,14 @@ If you create any variables of your own in the build function, it is
recommended to use the bash `local` keyword to scope the variable to inside
the build function.
+package() Function
+------------------
+An optional package() function can be specified in addition to the build() function.
+This function is run immediately after the build() function. When specified in
+combination with the fakeroot BUILDENV option in linkman:makepkg.conf[5], fakeroot
+usage will be limited to running the packaging stage. The build() function will be
+run as the user calling makepkg.
+
Install/Upgrade/Remove Scripting
--------------------------------
Pacman has the ability to store and execute a package-specific script when it