summaryrefslogtreecommitdiffstats
path: root/doc/PKGBUILD.5.txt
diff options
context:
space:
mode:
authorEnjolras <0enjolras0@laposte.net>2012-07-28 11:20:11 +0200
committerDan McGee <dan@archlinux.org>2012-08-01 16:18:06 +0200
commiteb25a18571d97c20046784f7c8a9815dc40512c7 (patch)
treee8f0b98e16f48b4db36dd29380a9dc8864e89a24 /doc/PKGBUILD.5.txt
parent065b7f863a25dac3699c23258b986312f4caac1c (diff)
downloadpacman-eb25a18571d97c20046784f7c8a9815dc40512c7.tar.gz
pacman-eb25a18571d97c20046784f7c8a9815dc40512c7.tar.xz
Add documentation for the prepare() function
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'doc/PKGBUILD.5.txt')
-rw-r--r--doc/PKGBUILD.5.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/doc/PKGBUILD.5.txt b/doc/PKGBUILD.5.txt
index 404a55ca..062b1ab6 100644
--- a/doc/PKGBUILD.5.txt
+++ b/doc/PKGBUILD.5.txt
@@ -296,6 +296,15 @@ If you create any variables of your own in the build function, it is
recommended to use the bash `local` keyword to scope the variable to inside
the build function.
+prepare() Function
+------------------
+An optional prepare() function can be specified in which operations that are
+to be run in order to prepare the sources for building (such as patching) are
+performed. This function is run after the source extraction and before the
+build() function and is skipped when source extraction is skipped. The
+function is run in `bash -e` mode, meaning any command that exits with a
+non-zero status will cause the function to exit.
+
check() Function
----------------
An optional check() function can be specified in which a packages test-suite