summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorCedric Staniewski <cedric@gmx.ca>2009-12-21 20:26:28 +0100
committerDan McGee <dan@archlinux.org>2010-03-15 00:34:16 +0100
commit5fe41df8a9eaac288433a54e216f96b1fe729c01 (patch)
tree489613b7b44d05b6a10190a134b19858192e2732 /etc/Makefile.am
parent22331fdadb1b055030a6f68e2bb9eed589187a10 (diff)
downloadpacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.gz
pacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.xz
makepkg: make strip options configurable
The newly added variables STRIP_BINARIES, STRIP_SHARED and STRIP_STATIC, that are set in makepkg.conf, specify the strip options used on binaries and shared and static libraries. In addition, files are now stripped more aggressively by default. Implements FS#13592 the way it was suggested by Allan in the comments. Signed-off-by: Cedric Staniewski <cedric@gmx.ca> Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 55c28c3b..25f18342 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -13,6 +13,9 @@ edit = sed \
-e 's|@PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \
-e 's|@PKGEXT[@]|$(PKGEXT)|g' \
-e 's|@SRCEXT[@]|$(SRCEXT)|g' \
+ -e 's|@STRIP_BINARIES[@]|$(STRIP_BINARIES)|g' \
+ -e 's|@STRIP_SHARED[@]|$(STRIP_SHARED)|g' \
+ -e 's|@STRIP_STATIC[@]|$(STRIP_STATIC)|g' \
-e 's|@CARCH[@]|$(CARCH)|g' \
-e 's|@CHOST[@]|$(CHOST)|g' \
-e 's|@ARCHSWITCH[@]|$(ARCHSWITCH)|g' \