summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-05-30 17:46:37 +0200
committerDan McGee <dan@archlinux.org>2007-05-30 17:46:37 +0200
commita6129bb789832ca1fa8966d511d7a0b96d2d9e53 (patch)
tree87a031da793ad8e3045f71c0ebc0ebaea86be6e3 /etc/Makefile.am
parentb6387b954f7c35d0d51978aac24ca6bd6a5308fc (diff)
downloadpacman-a6129bb789832ca1fa8966d511d7a0b96d2d9e53.tar.gz
pacman-a6129bb789832ca1fa8966d511d7a0b96d2d9e53.tar.xz
Finish making autoconf changes
Fix up everything in the etc/ directory so it is built at make-time and not configure-time. This reduces configure generated files to just the makefiles, which is the correct way to do things. This also allows a switch from @@REPO@@ to the more sane @REPO@ in mirrorlist.in, and kills the two-part generation of the mirror files. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 0bded95e..2bd7cc12 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -1,4 +1,25 @@
SUBDIRS = pacman.d abs
-EXTRA_DIST = makepkg.conf pacman.conf
dist_sysconf_DATA = makepkg.conf pacman.conf
+EXTRA_DIST = makepkg.conf.in pacman.conf.in
+
+# Files that should be removed, but which Automake does not know.
+MOSTLYCLEANFILES = $(dist_sysconf_DATA)
+
+#### Taken from the autoconf scripts Makefile.am ####
+edit = sed \
+ -e 's|@PACKAGE_VERSION[@]|$(PACKAGE_VERSION)|g' \
+ -e 's|@PACKAGE_NAME[@]|$(PACKAGE_NAME)|g' \
+ -e 's|@PKGEXT[@]|$(PKGEXT)|g' \
+ -e 's|@CARCH[@]|$(CARCH)|g' \
+ -e 's|@CHOST[@]|$(CHOST)|g' \
+ -e 's|@ARCHSWITCH[@]|$(ARCHSWITCH)|g' \
+ -e 's|@CARCHFLAGS[@]|$(CARCHFLAGS)|g'
+
+$(dist_sysconf_DATA): Makefile
+ rm -f $@ $@.tmp
+ $(edit) `test -f ./$@.in || echo $(srcdir)/`$@.in >$@.tmp
+ mv $@.tmp $@
+
+makepkg.conf: $(srcdir)/makepkg.conf.in
+pacman.conf: $(srcdir)/pacman.conf.in