summaryrefslogtreecommitdiffstats
path: root/etc/pacman.d/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-05-30 17:46:37 +0200
committerDan McGee <dan@archlinux.org>2007-05-30 17:46:37 +0200
commita6129bb789832ca1fa8966d511d7a0b96d2d9e53 (patch)
tree87a031da793ad8e3045f71c0ebc0ebaea86be6e3 /etc/pacman.d/Makefile.am
parentb6387b954f7c35d0d51978aac24ca6bd6a5308fc (diff)
downloadpacman-a6129bb789832ca1fa8966d511d7a0b96d2d9e53.tar.gz
pacman-a6129bb789832ca1fa8966d511d7a0b96d2d9e53.tar.xz
Finish making autoconf changes
Fix up everything in the etc/ directory so it is built at make-time and not configure-time. This reduces configure generated files to just the makefiles, which is the correct way to do things. This also allows a switch from @@REPO@@ to the more sane @REPO@ in mirrorlist.in, and kills the two-part generation of the mirror files. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'etc/pacman.d/Makefile.am')
-rw-r--r--etc/pacman.d/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/etc/pacman.d/Makefile.am b/etc/pacman.d/Makefile.am
index c8dded4b..f6f9051a 100644
--- a/etc/pacman.d/Makefile.am
+++ b/etc/pacman.d/Makefile.am
@@ -1,9 +1,22 @@
pkgsysconfdir = ${sysconfdir}/pacman.d
dist_pkgsysconf_DATA = community current extra release testing unstable
+EXTRA_DIST = mirrorlist.in
+#
+# Files that should be removed, but which Automake does not know.
+MOSTLYCLEANFILES = $(dist_pkgsysconf_DATA)
-$(dist_pkgsysconf_DATA): mirrorlist
- sed "s|@@REPO@@|$@|g" <$< >$@
+$(dist_pkgsysconf_DATA): Makefile
+ rm -f $@ $@.tmp
+ sed \
+ -e "s|@REPO[@]|$@|g" \
+ -e 's|@CARCH[@]|$(CARCH)|g' \
+ $(srcdir)/mirrorlist.in >$@.tmp
+ mv $@.tmp $@
-clean-local:
- rm -f $(dist_pkgsysconf_DATA)
+community: $(srcdir)/mirrorlist.in
+current: $(srcdir)/mirrorlist.in
+extra: $(srcdir)/mirrorlist.in
+release: $(srcdir)/mirrorlist.in
+testing: $(srcdir)/mirrorlist.in
+unstable: $(srcdir)/mirrorlist.in