summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2016-09-25 11:10:03 +0200
committerAllan McRae <allan@archlinux.org>2016-09-25 11:32:53 +0200
commit0e85c275a2ef041ce77c9ce185e207c1143329cc (patch)
tree562af4c78b9a17f757db811fbdd2d4b4bd071e5f /lib/libalpm/Makefile.am
parent0d2ba870c96d1b4b3d5fabfabe303bc6b1c989fd (diff)
downloadpacman-0e85c275a2ef041ce77c9ce185e207c1143329cc.tar.gz
pacman-0e85c275a2ef041ce77c9ce185e207c1143329cc.tar.xz
[RFC] Remove internal md5 and sha2 implementations
The internal implementations for md5 and sha256 checksums have not been merged from upstream sources for a long time. Instead of us carrying copies of code from other projects, we should just support building against multiple libraries that provide such functionality. This patch removes the md5 and sha2 code (originally obtained from PolarSSL) from our repository. The configure script will now error if at least one library supporting checksum generation is not present, with the only library currently supported being openssl. It will be relatively simple for other such libraries to be supported if anyone wishes to add them. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 4272ae72..945a6121 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -58,12 +58,6 @@ libalpm_la_SOURCES = \
util-common.h util-common.c \
version.c
-if !HAVE_LIBSSL
-libalpm_la_SOURCES += \
- md5.h md5.c \
- sha2.h sha2.c
-endif
-
libalpm_la_LDFLAGS = -no-undefined -version-info $(LIB_VERSION_INFO)
libalpm_la_CFLAGS = \