summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-01-03 11:49:33 +0100
committerAllan McRae <allan@archlinux.org>2013-01-04 12:49:37 +0100
commit27d9c25ee2fd6a03fb1ec1afdfbe105048875bae (patch)
treec5f6739e5f72a153fb358b2702965c39352ef630 /lib/libalpm/Makefile.am
parent965e1de2174148a7a6c0860a7514d9bb1969bf03 (diff)
downloadpacman-27d9c25ee2fd6a03fb1ec1afdfbe105048875bae.tar.gz
pacman-27d9c25ee2fd6a03fb1ec1afdfbe105048875bae.tar.xz
Split common utility functions for libalpm and pacman
There is duplicated code in the util.c files in the libalpm and pacman source code. Split this into a separate file so that it can be shared via a symlink. This prevents code divergence between the two code bases. Also, move mbasename and mdirname from pacman/util.c into util-common.c in preparation for the following patch that uses them to add an extension to pacsave files. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index c935e2db..5cf66b91 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -53,6 +53,7 @@ libalpm_la_SOURCES = \
sync.h sync.c \
trans.h trans.c \
util.h util.c \
+ util-common.h util-common.c \
version.c
if !HAVE_LIBSSL