summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-07-12 22:29:59 +0200
committerDan McGee <dan@archlinux.org>2012-08-02 16:39:08 +0200
commit72d3713cc7865af5f4d91410ad56ed4287be6109 (patch)
treeb7a4a0ddf620e5fcdaffa85c91a7352570217f24 /lib/libalpm/Makefile.am
parent70d8c2150e33d1a0b9e09d72c5091d661383d641 (diff)
downloadpacman-72d3713cc7865af5f4d91410ad56ed4287be6109.tar.gz
pacman-72d3713cc7865af5f4d91410ad56ed4287be6109.tar.xz
Move filelist functions into separate source file
We have a few of these and might as well gather them together. This also cleans up the code a bit by using an enum instead of integer values, as well as makes a "search for file in filelist" function public so frontends can do better than straight linear search of the filelists. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index ef448417..911e52bf 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -41,6 +41,7 @@ libalpm_la_SOURCES = \
diskspace.h diskspace.c \
dload.h dload.c \
error.c \
+ filelist.h filelist.c \
graph.h graph.c \
group.h group.c \
handle.h handle.c \