summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-03-11 22:10:02 +0100
committerDan McGee <dan@archlinux.org>2007-03-11 22:10:02 +0100
commit7f7da2b5fc01f46d28236384540c7ecfdac16a63 (patch)
treee9b3c02bdc36206e64878ceeef74a9fdf48112ff /lib/libalpm/Makefile.am
parentf94506396f25cba8a0d485c8d681482db0bd33bb (diff)
downloadpacman-7f7da2b5fc01f46d28236384540c7ecfdac16a63.tar.gz
pacman-7f7da2b5fc01f46d28236384540c7ecfdac16a63.tar.xz
* Fix group comparison issue and associated compilation warnings by using
the alpm strcmp operation which takes void* references. * We had this great visibility patch, but never actually took advantage of it. Added the right compile flag to make it work and added some more SYMEXPORTs where necessary to have a successful compile.
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 956c08ef..f96fdd0e 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -8,7 +8,7 @@ include_HEADERS = alpm_list.h alpm.h
localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
-AM_CFLAGS = -pedantic -D_GNU_SOURCE $(CFLAGS)
+AM_CFLAGS = -fvisibility=hidden -pedantic -D_GNU_SOURCE $(CFLAGS)
EXTRA_DIST = Doxyfile