summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-03-20 04:56:59 +0100
committerDave Reisner <dreisner@archlinux.org>2012-04-26 02:02:36 +0200
commit82b7122542e16354b560bae9c7f6f3608873a8e1 (patch)
tree1c80a7e17c8b9bb6afdfd9ca7179ad629e16758e /lib/libalpm/Makefile.am
parent953415c86a17c1db8bebbbaca89e6fd5783386b6 (diff)
downloadpacman-82b7122542e16354b560bae9c7f6f3608873a8e1.tar.gz
pacman-82b7122542e16354b560bae9c7f6f3608873a8e1.tar.xz
libalpm: add pkg-config file
No one seems to do this "correctly", but for the sake of having an easy method of detecting the presence and version of libalpm on a given system, we provide a straightforward .pc file. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 0781d5d8..ef448417 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -23,6 +23,9 @@ if ENABLE_GNU89_INLINE_CC
AM_CFLAGS += -fgnu89-inline
endif
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libalpm.pc
+
libalpm_la_SOURCES = \
add.h add.c \
alpm.h alpm.c \