summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2007-01-18 17:52:57 +0100
committerAaron Griffin <aaron@archlinux.org>2007-01-18 17:52:57 +0100
commit86b136bb592bf576a3da950fee153f6d4f5b9d15 (patch)
treef6289e427de5c5b2cfd3e3d37b75fc9506eb3bdb /lib/libalpm/Makefile.am
parent46e26ac5c8d15fbb2385ad972f2f69891a0bd8d0 (diff)
downloadpacman-86b136bb592bf576a3da950fee153f6d4f5b9d15.tar.gz
pacman-86b136bb592bf576a3da950fee153f6d4f5b9d15.tar.xz
Dan McGee <dpmcgee@gmail.com>
* Removed some unnecessary headers and library links * Made things static if possible * Cleaned up makefiles a bit * Fixed some old comments in the code * Fixed some errors the static code checker splint pointed out * Backwards arguments in a memset call in _alpm_db_read (could have been worse) * Other various small fixes Other: * Default to 80 columns when getcols cannot determine display width * Removal of ._install as a valid install file in packages
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 9f555d22..c5306d1f 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -40,7 +40,7 @@ include_HEADERS = alpm.h
libalpm_la_SOURCES = $(TARGETS)
libalpm_la_LDFLAGS = -no-undefined -version-info $(PM_VERSION_INFO)
-libalpm_la_LIBADD = -ldownload
+libalpm_la_LIBADD = -larchive -ldownload
if HAS_DOXYGEN
all: doxygen.in