summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-10-15 21:31:03 +0200
committerAaron Griffin <aaron@archlinux.org>2006-10-15 21:31:03 +0200
commitd37ad048732fbcef38aec001993553896dbe4198 (patch)
treec80472214aae0cd94c32ac00d613d38d51bc1adf /lib/libalpm/Makefile.am
parent83381bd21748d79f46247fab17877bc5c440a8de (diff)
downloadpacman-d37ad048732fbcef38aec001993553896dbe4198.tar.gz
pacman-d37ad048732fbcef38aec001993553896dbe4198.tar.xz
Merged frugalware changes (too many to list). Also added some config file
handling changes (support [sections] to carry over to included files - this helps with backwards compatibility with existing pacman config files)
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 5151f4dd..a656d7e6 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -1,6 +1,7 @@
AUTOMAKE_OPTIONS = gnu
DEFINES = -pedantic -D_GNU_SOURCE
-AM_CFLAGS = $(DEFINES)
+AM_CFLAGS = $(DEFINES) \
+ -I$(top_srcdir)/lib/libftp
SUBDIRS = po
localedir = $(datadir)/locale
@@ -8,6 +9,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
TARGETS = md5driver.c \
md5.c \
+ sha1.c \
util.c \
list.c \
log.c \
@@ -26,8 +28,9 @@ TARGETS = md5driver.c \
remove.c \
sync.c \
handle.c \
- alpm.c
-TARGETS += be_files.c
+ server.c \
+ alpm.c \
+ be_files.c
lib_LTLIBRARIES = libalpm.la
@@ -36,6 +39,7 @@ include_HEADERS = alpm.h
libalpm_la_SOURCES = $(TARGETS)
libalpm_la_LDFLAGS = -no-undefined -version-info $(PM_VERSION_INFO)
+libalpm_la_LIBADD = $(top_srcdir)/lib/libftp/libftp.la
if HAS_DOXYGEN
all: doxygen.in
@@ -44,4 +48,3 @@ doxygen.in:
doxygen Doxyfile
endif
-