summaryrefslogtreecommitdiffstats
path: root/lib/libalpm/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-06-04 16:37:00 +0200
committerDan McGee <dan@archlinux.org>2007-06-04 23:00:30 +0200
commitd9ff7bbcd2eef852f18ad65d79aa6b6f7c58535c (patch)
tree1f8fb2f1b794906300ca14ac68b592136a898de1 /lib/libalpm/Makefile.am
parenta094deacf4f6abbef10c6acf38190d4fa9d34f0e (diff)
downloadpacman-d9ff7bbcd2eef852f18ad65d79aa6b6f7c58535c.tar.gz
pacman-d9ff7bbcd2eef852f18ad65d79aa6b6f7c58535c.tar.xz
Remove hardcoded defines from libalpm
Remove any use of the former path variables defined by the Makefiles or config.h. These are now runtime configurable only with pacman.conf (or by using flags on the command line). Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'lib/libalpm/Makefile.am')
-rw-r--r--lib/libalpm/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/lib/libalpm/Makefile.am b/lib/libalpm/Makefile.am
index 285a9a83..e3d6a188 100644
--- a/lib/libalpm/Makefile.am
+++ b/lib/libalpm/Makefile.am
@@ -10,11 +10,7 @@ cachedir = ${localstatedir}/cache/pacman/pkg/
lib_LTLIBRARIES = libalpm.la
include_HEADERS = alpm_list.h alpm.h
-DEFS = -DLOCALEDIR=\"@localedir@\" \
- -DLOCKFILE=\"$(lockfile)\" \
- -DDBPATH=\"$(dbpath)\" \
- -DCACHEDIR=\"$(cachedir)\" \
- @DEFS@
+DEFS = -DLOCALEDIR=\"@localedir@\" @DEFS@
AM_CFLAGS = -fvisibility=hidden -pedantic -D_GNU_SOURCE