summaryrefslogtreecommitdiffstats
path: root/proto/PKGBUILD.proto
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2011-06-25 22:45:01 +0200
committerDan McGee <dan@archlinux.org>2011-06-30 20:37:58 +0200
commit6633b8e5c290dbb1b0382f3f960e1f7134247a68 (patch)
tree3d7021ecc7b2d1d9121bcd8e062deab12ef3b745 /proto/PKGBUILD.proto
parent98a2fc8deba6be37729c26cf68e9927f6466c95e (diff)
downloadpacman-6633b8e5c290dbb1b0382f3f960e1f7134247a68.tar.gz
pacman-6633b8e5c290dbb1b0382f3f960e1f7134247a68.tar.xz
move proto files to new subdirectory, proto/
Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'proto/PKGBUILD.proto')
-rw-r--r--proto/PKGBUILD.proto47
1 files changed, 47 insertions, 0 deletions
diff --git a/proto/PKGBUILD.proto b/proto/PKGBUILD.proto
new file mode 100644
index 00000000..98172d8d
--- /dev/null
+++ b/proto/PKGBUILD.proto
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=NAME
+pkgver=VERSION
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=()
+url=""
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: