summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2011-06-15 05:52:56 +0200
committerDan McGee <dan@archlinux.org>2011-06-15 16:19:56 +0200
commit06cb713f3915cc858de0388b0a5232326101a9fa (patch)
treeb22bd97c6251b939a67539a97df187d460faf609 /scripts/Makefile.am
parente27e658033d500c22b9dd4974fa3fbcc378f35b9 (diff)
downloadpacman-06cb713f3915cc858de0388b0a5232326101a9fa.tar.gz
pacman-06cb713f3915cc858de0388b0a5232326101a9fa.tar.xz
Clean up makefile for script generation
We no longer have any python scripts in our scripts/ directory so we can simplify the makefile a bit. Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am13
1 files changed, 5 insertions, 8 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 1abf9c4c..1a9840d7 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -29,7 +29,7 @@ LIBRARY = \
library/parse_options.sh
# Files that should be removed, but which Automake does not know.
-MOSTLYCLEANFILES = $(bin_SCRIPTS) *.tmp
+MOSTLYCLEANFILES = $(bin_SCRIPTS)
if USE_GIT_VERSION
GIT_VERSION := $(shell sh -c 'git describe --abbrev=4 --dirty | sed s/^v//')
@@ -62,13 +62,10 @@ edit = sed \
# third 'test' line- make sure one of the two checks succeeded
$(OURSCRIPTS): Makefile
@echo ' ' GEN $@;
- @rm -f $@ $@.tmp
- @test -f $(srcdir)/$@.sh.in && m4 -P -I $(srcdir) $(srcdir)/$@.sh.in | $(edit) >$@.tmp || true
- @test -f $(srcdir)/$@.py.in && m4 -P -I $(srcdir) $(srcdir)/$@.py.in | $(edit) >$@.tmp || true
- @test -f $@.tmp || false
- @chmod +x $@.tmp
- @chmod a-w $@.tmp
- @mv $@.tmp $@
+ @rm -f $@
+ @test -f $(srcdir)/$@.sh.in && m4 -P -I $(srcdir) $(srcdir)/$@.sh.in | $(edit) >$@
+ @chmod +x $@
+ @chmod a-w $@
makepkg: \
$(srcdir)/makepkg.sh.in \