summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-05-29 22:53:15 +0200
committerDan McGee <dan@archlinux.org>2007-05-29 22:53:15 +0200
commit103c7243a2d50dd46c0b5efefdc2e1b1d24e30e0 (patch)
treead7914cb0864b1ae80f44dc49f967e20f888db59 /scripts/Makefile.am
parent2760828e9dff1250c1160b7df2f376107ffe134f (diff)
downloadpacman-103c7243a2d50dd46c0b5efefdc2e1b1d24e30e0.tar.gz
pacman-103c7243a2d50dd46c0b5efefdc2e1b1d24e30e0.tar.xz
Get --help and --version options working on all scripts
Added the autoconf option std-options to the scripts/ directory, which checks to ensure all programs have both --help and --version options. A few things needed cleaning up to get this working. To test these types of options, use the 'make distcheck' target. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index ddacb0e6..45f0957d 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,6 +1,5 @@
-# TODO: this would be nice to enable, but we need --help and --version
-# flags on all of our scripts first (this is what it checks)
-#AUTOMAKE_OPTIONS = std-options
+# enforce that all scripts have a --help and --version option
+AUTOMAKE_OPTIONS = std-options
bin_SCRIPTS = \
abs \