summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorXavier Chantry <shiningxc@gmail.com>2008-06-17 00:09:45 +0200
committerDan McGee <dan@archlinux.org>2008-06-30 00:37:45 +0200
commit11695bd0d7d8efa32066c3adf25007a896661da9 (patch)
tree2e0dc2158ec31e617936cb9249a569bdb6322d31 /scripts/Makefile.am
parentb15fb504a19831200b86a43646d8def89560b61c (diff)
downloadpacman-11695bd0d7d8efa32066c3adf25007a896661da9.tar.gz
pacman-11695bd0d7d8efa32066c3adf25007a896661da9.tar.xz
repo-add cleanup.
* change ln -s to ln -sf in the Makefile to prevent a failure when the link already exists. * make test_repo_db_file simpler and more natural, move the complexity out of it. * remove one $cmd = repo-remove check that wasn't needed Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 283556e3..7dccff9d 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -58,6 +58,6 @@ pacman-optimize: $(srcdir)/pacman-optimize.sh.in
rankmirrors: $(srcdir)/rankmirrors.py.in
repo-add: $(srcdir)/repo-add.sh.in
repo-remove: $(srcdir)/repo-add.sh.in
- ln -s repo-add repo-remove
+ ln -sf repo-add repo-remove
# vim:set ts=2 sw=2 noet: